PHP

Trying to get XMPPHP library to work with php 5.3 and beyond

Trying to get XMPPHP library to work with php 5.3 and beyond
Thu, 03/10/2011 - 10:34 | by Todd
#Use XMPPHP_Log::LEVEL_VERBOSE to get more logging for error reports
#If this doesn't work, are you running 64-bit PHP with < 5.2.6?

Bringing it up to 5.3+:

Running XMPPHP against an OpenFire Jabber/XMPP server:

'Not supporting crypto' - WAMP - SSL not enabled, WAMP->php Extensions->php_openssl put a checkmark and restart WAMP

Replace all 'split' with 'explode' - just the word, leave all other syntax alone. Appears in line 121 of 'roster.php' and line ??? of XMPP.php

Comment out line 16 of test script - there is no 'subject' in the data

Need to change the test for whether this response is a message or a presence.

>> Notice: Trying to get property of non-object in C:\wamp\www\XMPP_test\XMPPHP\XMPP.php on line 233

Tags: 

Pages

Subscribe to RSS - PHP